summary refs log tree commit diff
path: root/gnu/packages/enchant.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-28 17:15:00 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-26 00:33:01 +0200
commit9a59b29411e2f007a6ba32b88d3b6f50bd6c1f45 (patch)
treef1ef9d334e2c5b61405344dac542bf51f66c3e16 /gnu/packages/enchant.scm
parent18ef85b64a3433bccf8dc8b32d338de91fd85a8a (diff)
downloadguix-9a59b29411e2f007a6ba32b88d3b6f50bd6c1f45.tar.gz
gnu: enchant: Propagate Glib.
* gnu/packages/enchant.scm (enchant)[inputs]: Move GLIB ...
[propagated-inputs]: ... here.  New field.
Diffstat (limited to 'gnu/packages/enchant.scm')
-rw-r--r--gnu/packages/enchant.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index b5e9084a42..c3f75ccf2e 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -43,8 +43,10 @@
     (arguments
      '(#:configure-flags '("--disable-static")))
     (inputs
-      `(("aspell" ,aspell)    ;; Currently, the only supported backend in Guix
-        ("glib" ,glib)))      ;; is aspell. (This information might be old)
+     `(("aspell" ,aspell)))   ;; Currently, the only supported backend in Guix
+    (propagated-inputs        ;; is aspell. (This information might be old)
+     ;; Required by enchant.pc.
+     `(("glib" ,glib)))
     (native-inputs
      `(("glib:bin" ,glib "bin")
        ("pkg-config" ,pkg-config)))