summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-20 23:38:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-20 23:38:56 +0200
commit6cb1ef9ea28ee14b3bb5442e8af1f54c27802f09 (patch)
treec2c35f733d250f86eb052d174fcb1c24a54fea79 /gnu/packages/engineering.scm
parent20e4ee1e3b7044d9f64de02c6237b00e5a57da35 (diff)
parent010689e7067df1288af29176f4a8639de816b1ef (diff)
downloadguix-6cb1ef9ea28ee14b3bb5442e8af1f54c27802f09.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 9b0f00c7be..7d48414889 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1248,17 +1248,17 @@ bindings for Python, Java, OCaml and more.")
 (define-public radare2
   (package
     (name "radare2")
-    (version "2.5.0")
+    (version "3.5.1")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://radare.mikelloc.com/get/" version "/"
-                                  name "-" version ".tar.gz"))
+              (uri (string-append "https://radare.mikelloc.com/get/" version "/"
+                                  "radare2-" version ".tar.gz"))
               (sha256
                (base32
-                "17h4ba5qqahfi8mi4x2dcvq87cqpir5v2dlaqbvmay6vby4zh4v7"))
+                "174x5545fw2nyf000gd46hi7rx2bn3bw5bsnvizn9yi99pn7m4mw"))
               (modules '((guix build utils)))
               (snippet
-                '(begin
+               '(begin
                   (substitute* "libr/asm/p/Makefile"
                     (("LDFLAGS\\+=") "LDFLAGS+=-Wl,-rpath=$(LIBDIR) "))
                   (substitute* "libr/parse/p/Makefile"
@@ -1268,7 +1268,7 @@ bindings for Python, Java, OCaml and more.")
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f; tests require git and network access
+     '(#:tests? #f                      ; tests require git and network access
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'mklibdir