summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-12-03 11:06:25 -0300
committerVinicius Monego <monego@posteo.net>2023-02-06 19:39:29 -0300
commit2a6cee99b38f17850bf0e5294b70ce0ee402802d (patch)
tree0b3b9f3270e1023699de739adf874eceffb674d7 /gnu/packages/engineering.scm
parente8ad02e7065f5226c433c83b400a25e41188b88d (diff)
downloadguix-2a6cee99b38f17850bf0e5294b70ce0ee402802d.tar.gz
gnu: Add python-scikit-rf.
* gnu/packages/engineering.scm (python-scikit-rf): New variable.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 466bb3cc03..78059ceb7e 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2384,6 +2384,42 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
 measurement devices and test equipment via GPIB, RS232, Ethernet or USB.")
     (license license:expat)))
 
+(define-public python-scikit-rf
+  (package
+    (name "python-scikit-rf")
+    (version "0.24.1")
+    (source (origin
+              (method git-fetch) ;PyPI misses some files required for tests
+              (uri (git-reference
+                    (url "https://github.com/scikit-rf/scikit-rf")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "1shp8q8324dkwf448mv9zzi7krx882p122ma4fk015qz91sg4wff"))
+              (file-name (git-file-name name version))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-matplotlib
+                             python-networkx
+                             python-numpy
+                             python-openpyxl
+                             python-pandas
+                             python-pyqt
+                             python-pyqtgraph
+                             python-qtpy
+                             python-scipy))
+    (native-inputs (list python-coverage
+                         python-flake8
+                         python-nbval
+                         python-networkx
+                         python-pytest-7.1
+                         python-pytest-cov
+                         python-pyvisa))
+    (home-page "https://scikit-rf.org/")
+    (synopsis "Radio frequency and Microwave Engineering Scikit")
+    (description "Scikit-rf, or @code{skrf}, is a Python package for RF and
+Microwave engineering.")
+    (license license:bsd-3)))
+
 (define-public openscad
   (package
     (name "openscad")