summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
committerMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
commit647888845c0d7b9ea1b51a3e3492d4d2382f4468 (patch)
treebe34c5ec88db452c63253dc4a15f9f4cf199b1e6 /gnu/packages/engineering.scm
parentfe15613cdf8623574ce64c05416dd3fab41eef86 (diff)
parentc657716ede8932da356635802534aa13205a6ecd (diff)
downloadguix-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index aee60bd697..c236d8cd67 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -699,12 +699,12 @@ language.")
       (arguments
        `(#:out-of-source? #t
          #:tests? #f ; no tests
+         #:build-type "Release"
          #:configure-flags
          (list "-DKICAD_STABLE_VERSION=ON"
                "-DKICAD_REPO_NAME=stable"
                ,(string-append "-DKICAD_BUILD_VERSION=4.0-"
                                (string-take commit 7))
-               "-DCMAKE_BUILD_TYPE=Release"
                "-DKICAD_SKIP_BOOST=ON"; Use our system's boost library.
                "-DKICAD_SCRIPTING=ON"
                "-DKICAD_SCRIPTING_MODULES=ON"
@@ -865,7 +865,7 @@ the 'showing the effect of'-style of operation.")
     (inputs
      `(("boost" ,boost)))
     (native-inputs
-     `(("python-2", python-2)
+     `(("python-2" ,python-2)
        ("python2-cheetah" ,python2-cheetah)))
     (home-page "http://libvolk.org/")
     (synopsis "Vector-Optimized Library of Kernels")