summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-12 21:46:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-14 14:15:33 +0100
commitc2ff0e2d13b276dea7676cd3d7cf10ce68e3d4e1 (patch)
tree1fe89df55cf8aa30fcaf69ee54f3551a8f054b16 /gnu/packages/engineering.scm
parent6822730c8de2ff33902ba7cf0d4af80226b62775 (diff)
downloadguix-c2ff0e2d13b276dea7676cd3d7cf10ce68e3d4e1.tar.gz
gnu: pcb: Update to 4.3.0.
* gnu/packages/engineering.scm (pcb): Update to 4.3.0.
[arguments]: Remove obsolete build phases.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 25fe1398dc..9cbabd4ef6 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -423,39 +423,19 @@ features.")))
 (define-public pcb
   (package
     (name "pcb")
-    (version "4.0.2")
+    (version "4.3.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pcb/pcb/pcb-" version
                                   "/pcb-" version ".tar.gz"))
               (sha256
                (base32
-                "1a7rilp75faidny0r4fdwdxkflyrqp6svxv9lbg7h868293962iz"))))
+                "0ppv8cblw0h70laly4zp8gmbxkbzzhbbjgw13pssgaw4mx32z1df"))))
     (build-system gnu-build-system)
     (arguments
      (list
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'use-wish8.6
-            (lambda _
-              (substitute* "configure"
-                (("wish85") "wish8.6"))))
-          ;; It checks for "xhost", which we don't have.  This shouldn't
-          ;; matter, because the test is supposed to be skipped, but it causes
-          ;; "run_tests.sh" (and thus the "check" phase) to fail.
-          (add-after 'unpack 'fix-check-for-display
-            (lambda _
-              (substitute* "tests/run_tests.sh"
-                (("have_display=no") "have_display=yes"))))
-          (add-after 'install 'wrap
-            (lambda* (#:key inputs #:allow-other-keys)
-              ;; FIXME: Mesa tries to dlopen libudev.so.0 and fails.  Pending a
-              ;; fix of the mesa package we wrap the pcb executable such that
-              ;; Mesa can find libudev.so.0 through LD_LIBRARY_PATH.
-              (let ((path (dirname
-                           (search-input-file inputs "/lib/libudev.so"))))
-                (wrap-program (string-append #$output "/bin/pcb")
-                  `("LD_LIBRARY_PATH" ":" prefix (,path))))))
           (add-before 'check 'pre-check
             (lambda _
               (system "Xvfb :1 &")