summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorMalte Frank Gerdes <malte.f.gerdes@gmail.com>2022-04-07 17:21:13 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-07 22:32:01 +0200
commit79b50d5d5b465504511d9fbd735e7b3ddb6eb1de (patch)
treebd8cb38ac20374f434e201e8df1c0a93ce5c8315 /gnu/packages/engineering.scm
parentf14d43b367c52c31e63266539547b3daaf3fa7c8 (diff)
downloadguix-79b50d5d5b465504511d9fbd735e7b3ddb6eb1de.tar.gz
gnu: Add libcharon.
* gnu/packages/engineering.scm (libcharon): New variable.

Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 0fadf3e1d1..040c2a3ef0 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3430,3 +3430,27 @@ compiled translations.  Prebuilt Firmware files are removed.")
 related desktop applications using PyQt5.  It belongs to the Cura project
 from Ultimaker.")
     (license license:lgpl3+)))
+
+(define-public libcharon
+  (package
+    (name "libcharon")
+    (version "4.13.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+               (url "https://github.com/Ultimaker/libCharon")
+               (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ibv15y7lfxs09k6rbc3kiaz13gq3v9vqxrk20rqp6bdclk3izff"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     (list python-pytest))
+    (inputs
+     (list python))
+    (home-page "https://github.com/Ultimaker/libCharon")
+    (synopsis "File metadata and streaming library")
+    (description "LibCharon is a Python file metadata and streaming library.  It
+belongs to the Cura project from Ultimaker.")
+    (license license:lgpl3+)))