summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorqblade <qblade@protonmail.com>2021-02-23 01:13:09 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-25 10:44:05 +0100
commitc1da9829f8b6d7c130ff3cc04ef7b15a5bb54825 (patch)
tree23c8c344a064370ecb7e28e92182998b8844c5f3 /gnu/packages/engineering.scm
parent801932f4dbf09cb40508025595c24f626a12ff0d (diff)
downloadguix-c1da9829f8b6d7c130ff3cc04ef7b15a5bb54825.tar.gz
gnu: Add python-esptool.
* gnu/packages/engineering.scm (python-esptool-3.0): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 034dabc3f9..5e5cb02dd7 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -21,6 +21,7 @@
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -106,6 +107,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
@@ -1522,6 +1524,32 @@ bindings for Python, Java, OCaml and more.")
 (define-public python2-capstone
   (package-with-python2 python-capstone))
 
+
+(define-public python-esptool-3.0
+  (package
+    (name "python-esptool")
+    (version "3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "esptool" version))
+       (sha256
+        (base32
+         "0d69rd9h8wrzjvfrc66vmz4qd5hly2fpdcwj2bdrlb7dbwikv5c7"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;XXX: require python-reedsolo
+    (propagated-inputs
+     `(("python-ecdsa" ,python-ecdsa)
+       ("python-pyaes" ,python-pyaes)
+       ("python-pyserial" ,python-pyserial)))
+    (home-page "https://github.com/espressif/esptool")
+    (synopsis "Bootloader utility for Espressif ESP8266 & ESP32 chips")
+    (description
+     "@code{esptool.py} is a Python-based utility to communicate with the ROM
+bootloader in Espressif ESP8266 & ESP32 series chips.")
+    (license license:gpl2+)))
+
 (define-public radare2
   (package
     (name "radare2")