summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-07-06 18:14:07 +0000
committerLudovic Courtès <ludo@gnu.org>2022-07-18 00:21:32 +0200
commitd58dc0fcd23c1bd496614e123f78493ab6e08bbe (patch)
treee7f8ba5157c8fe7e6707e297db031ee923d6ddcb /gnu/packages/engineering.scm
parentc493ecfa9bd6c68cd63a321edb84c7becd1c1905 (diff)
downloadguix-d58dc0fcd23c1bd496614e123f78493ab6e08bbe.tar.gz
gnu: pcb2gcode: Update to 2.4.0.
* gnu/packages/engineering.scm (pcb2gcode): Update to 2.4.0.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 4d23242a33..6eefd14d7e 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -35,6 +35,7 @@
 ;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2857,20 +2858,23 @@ data structures and to operate on them.")
     (license license:gpl3+)))
 
 (define-public pcb2gcode
+  ;; Take some additional commits after v2.4.0 to fix build against
+  ;; geos 3.10.1.
+  (let ((commit "ae41f9fe41e57ee5d0cced6c3b3c8aea9c3f5392"))
     (package
      (name "pcb2gcode")
-     (version "2.1.0")
+     (version (git-version "2.4.0" "1" commit))
      (source
       (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/pcb2gcode/pcb2gcode")
-             (commit (string-append "v" version))
+             (commit commit)
              (recursive? #t)))
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0nzglcyh6ban27cc73j4l7w7r9k38qivq0jz8iwnci02pfalw4ry"))))
+         "1r1qmvpn5ffi2xpq2gigwsk8kn79s4s2ywfvicwf8i7rzwhkdf17"))))
      (build-system gnu-build-system)
      (inputs
       (list boost
@@ -2887,7 +2891,7 @@ data structures and to operate on them.")
 and drilling of PCBs.  It takes Gerber files as input and outputs G-code files
 for the milling of PCBs.  It also includes an autoleveller for the automatic
 dynamic calibration of the milling depth.")
-     (license license:gpl3+)))
+     (license license:gpl3+))))
 
 (define-public syscall-intercept
   ;; Upstream provides no tag. Also, last version update is 4 years old.