summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-29 04:22:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-29 04:25:56 +0200
commit2f04eb48523937826ebf1d867931d36cff53fd3a (patch)
tree0205c7bbd99d55fa7d18db4a582171a4fd56cb83 /gnu/packages/engineering.scm
parent748ab8b3642a339919ce0bba6cdbc2423a95e029 (diff)
downloadguix-2f04eb48523937826ebf1d867931d36cff53fd3a.tar.gz
gnu: minicom: Don't use a vanished tarball.
* gnu/packages/engineering.scm (minicom)[source]: Use GIT-FETCH and
GIT-FILE-NAME.  Switch to salsa from dead alioth.
[arguments]: Replace the default ‘bootstrap’ phase.
[native-inputs]: Add autoconf, automake, gettext-minimal, and pkg-config.
[home-page]: Update to salsa from dead alioth.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm25
1 files changed, 18 insertions, 7 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cbfb6595b7..b34eb415d5 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1081,25 +1081,36 @@ use on a given system.")
     (version "2.7.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://alioth.debian.org/frs/download.php/"
-                           "file/4215/" name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://salsa.debian.org/minicom-team/minicom.git")
+             (commit (string-append "v" version))))
        (sha256
-        (base32
-         "1wa1l36fa4npd21xa9nz60yrqwkk5cq713fa3p5v0zk7g9mq6bsk"))))
+        (base32 "0f36wv015zpz1x895qv0z6marlynzyh0d5mfkyd7lfyy2xd1i2w0"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--enable-lock-dir=/var/lock")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-lock-check
+         (replace 'bootstrap
+           ;; autogen.sh needlessly hard-codes aclocal-1.14.
+           (lambda _
+             (invoke "autoreconf" "-vif")
+             #t))
+         (add-before 'configure 'patch-lock-check
            (lambda _
              (substitute* "configure"
                (("test -d [$]UUCPLOCK") "true"))
              #t)))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("ncurses" ,ncurses)))
-    (home-page "https://alioth.debian.org/projects/minicom/")
+    (home-page "https://salsa.debian.org/minicom-team/minicom")
     (synopsis "Serial terminal emulator")
     (description "@code{minicom} is a serial terminal emulator.")
     (license license:gpl2+)))