summary refs log tree commit diff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-28 16:06:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-28 17:05:40 +0200
commit73ff9d6e0eedae5c365c784906c55918a2ed7507 (patch)
treec52afd3de7054f7b0fa417005590a32d98cddebf /gnu/packages/enlightenment.scm
parent49cf2a40d21fc54f387fa5979a5c0979059e9420 (diff)
downloadguix-73ff9d6e0eedae5c365c784906c55918a2ed7507.tar.gz
gnu: enlightenment: Update to 0.25.0.
* gnu/packages/enlightenment.scm (enlightenment): Update to 0.25.0.
[arguments]: Remove unneeded configure-flags. Don't remove phase which
isn't part of the build system. Remove trailing #t from phases.
[inputs]: Add libexif.
* gnu/packages/patches/enlightenment-fix-setuid-path.patch: Refresh patch.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index f8ab890f30..7bf7ba73e6 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -296,7 +296,7 @@ Libraries with some extra bells and whistles.")
 (define-public enlightenment
   (package
     (name "enlightenment")
-    (version "0.24.2")
+    (version "0.25.0")
     (source (origin
               (method url-fetch)
               (uri
@@ -304,21 +304,16 @@ Libraries with some extra bells and whistles.")
                               "enlightenment/enlightenment-" version ".tar.xz"))
               (sha256
                (base32
-                "1wfz0rwwsx7c1mkswn4hc9xw1i6bsdirhxiycf7ha2vcipqy465y"))
+                "01nzyvjy06043m01fdb1309xx3wxxg0s3hj9g9di7jjsxp774vkx"))
               (patches (search-patches "enlightenment-fix-setuid-path.patch"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
-       (let ((efl (assoc-ref %build-inputs "efl")))
-         (list "-Dsystemd=false"
-               "-Dpackagekit=false"
-               "-Dwl=true"
-               (string-append "-Dedje-cc=" efl "/bin/edje_cc")
-               (string-append "-Deldbus-codegen=" efl "/bin/eldbus-codegen")
-               (string-append "-Deet=" efl "/bin/eet")))
+       (list "-Dsystemd=false"
+             "-Dpackagekit=false"
+             "-Dwl=true")
        #:phases
        (modify-phases %standard-phases
-         (delete 'bootstrap) ; We don't want to run the autogen script.
          (add-before 'configure 'set-system-actions
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "HOME" "/tmp")
@@ -356,8 +351,7 @@ Libraries with some extra bells and whistles.")
                  (("/bin/umount") "/run/setuid-programs/umount")
                  (("/usr/bin/eject") "/run/current-system/profile/bin/eject"))
                (substitute* "src/bin/system/e_system_power.c"
-                 (("systemctl") "loginctl"))
-               #t))))))
+                 (("systemctl") "loginctl"))))))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)))
@@ -368,10 +362,11 @@ Libraries with some extra bells and whistles.")
        ("dbus" ,dbus)
        ("freetype" ,freetype)
        ("libdrm" ,libdrm)
+       ("libexif" ,libexif)
        ("libxcb" ,libxcb)
        ("libxext" ,libxext)
        ("linux-pam" ,linux-pam)
-       ("puleseaudio" ,pulseaudio)
+       ("pulseaudio" ,pulseaudio)
        ("setxkbmap" ,setxkbmap)
        ("xcb-util-keysyms" ,xcb-util-keysyms)
        ("xkeyboard-config" ,xkeyboard-config)