summary refs log tree commit diff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-08 12:07:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-02-08 12:07:41 +0200
commitfb6714d13f734e2ebea2ef7d42f57013dd124478 (patch)
treeb36566ea42b0d4e70fcbfac2ac88737da0f0f0b7 /gnu/packages/enlightenment.scm
parentc8af59e845ab1372082a4d00d5da46fd13344d20 (diff)
downloadguix-fb6714d13f734e2ebea2ef7d42f57013dd124478.tar.gz
gnu: efl: Build with librsvg-for-system.
* gnu/packages/enlightenment.scm (efl)[inputs]: Replace conditional
librsvg with librsvg-for-system.
[arguments]: Remove configure-flag disabling librsvg support.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 254002d1ca..c7832b144c 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -93,11 +93,7 @@
        ("ibus" ,ibus)
        ("mesa" ,mesa)
        ("libraw" ,libraw)
-       ;; Only enable the optional SVG support on x86_64, as this is the only
-       ;; architecture where librsvg can be built.
-       ,@(if (target-x86-64?)
-             `(("librsvg" ,librsvg))
-             '())
+       ("librsvg" ,(librsvg-for-system))
        ("libspectre" ,libspectre)
        ("libtiff" ,libtiff)
        ("libxau" ,libxau)
@@ -151,11 +147,6 @@
          "-Dmount-path=/run/setuid-programs/mount"
          "-Dunmount-path=/run/setuid-programs/umount"
          "-Dnetwork-backend=connman"
-         ;; Add 'rsvg' to the default list (json, avif, heif) of disabled loaders
-         ;; unless librsvg is available.
-         ,,@(if (target-x86-64?)
-                '()
-                (list "-Devas-loaders-disabler=json,avif,heif,rsvg"))
          ;; For Wayland.
          "-Dwl=true"
          "-Ddrm=true")