summary refs log tree commit diff
path: root/gnu/packages/entr.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 12:09:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:19 +0100
commitfbc70c97c60dfe3bbdbf525607e1fbcbb17adb24 (patch)
treea56e01b098318018a2fee153dc7b82ed33dda3e1 /gnu/packages/entr.scm
parent7492af9be7ba33d94f5784b9eaf3ebeea487e64a (diff)
downloadguix-fbc70c97c60dfe3bbdbf525607e1fbcbb17adb24.tar.gz
gnu: entr: Update to 4.1.
* gnu/packages/entr.scm (entr): Update to 4.1.
[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/entr.scm')
-rw-r--r--gnu/packages/entr.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/entr.scm b/gnu/packages/entr.scm
index 11d28e60f7..19667ce23f 100644
--- a/gnu/packages/entr.scm
+++ b/gnu/packages/entr.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,33 +27,35 @@
 (define-public entr
   (package
     (name "entr")
-    (version "3.6")
+    (version "4.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://entrproject.org/code/entr-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1sy81np6kgmq04kfn2ckf4fp7jcf5d1963shgmapx3al3kc4c9x4"))))
+                "0y7gvyf0iykpf3gfw09m21hy51m6qn4cpkbrm4nnn7pwrwycj0y5"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
-       #:phases (modify-phases %standard-phases
-                  (replace 'configure
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let ((out (assoc-ref outputs "out")))
-                        (setenv "CONFIG_SHELL" (which "bash"))
-                        (setenv "CC" (which "gcc"))
-                        (setenv "DESTDIR" (string-append out "/"))
-                        (setenv "PREFIX" "")
-                        (setenv "MANPREFIX" "man")
-                        (zero? (system* "./configure")))))
-                  (add-before 'build 'remove-fhs-file-names
-                    (lambda _
-                      ;; Use the tools available in $PATH.
-                      (substitute* "entr.c"
-                        (("/bin/cat") "cat")
-                        (("/usr/bin/clear") "clear")))))))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (setenv "CONFIG_SHELL" (which "bash"))
+               (setenv "CC" (which "gcc"))
+               (setenv "DESTDIR" (string-append out "/"))
+               (setenv "PREFIX" "")
+               (setenv "MANPREFIX" "man")
+               (invoke "./configure"))))
+         (add-before 'build 'remove-fhs-file-names
+           (lambda _
+             ;; Use the tools available in $PATH.
+             (substitute* "entr.c"
+               (("/bin/cat") "cat")
+               (("/usr/bin/clear") "clear"))
+             #t)))))
     (home-page "http://entrproject.org/")
     (synopsis "Run arbitrary commands when files change")
     (description