summary refs log tree commit diff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 04:31:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 05:15:21 +0200
commited672882626d30d3e0deba6d9265ac4d321113f2 (patch)
tree2bd600ad58338110dfe8928153945c9bce28d696 /gnu/packages/erlang.scm
parenteb5a664344fc2078f56085d91f04fa2f38d8d678 (diff)
downloadguix-ed672882626d30d3e0deba6d9265ac4d321113f2.tar.gz
gnu: erlang: Don't use unstable tarball.
* gnu/packages/erlang.scm (erlang)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index f0b2f350c2..219fa5a0dc 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -24,6 +24,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix utils)
   #:use-module (gnu packages)
@@ -40,16 +41,17 @@
     (name "erlang")
     (version "21.0")
     (source (origin
-              (method url-fetch)
+              (method git-fetch)
               ;; The tarball from http://erlang.org/download contains many
               ;; pre-compiled files, so we use this snapshot of the source
               ;; repository.
-              (uri (string-append "https://github.com/erlang/otp/archive/OTP-"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (uri (git-reference
+                    (url "https://github.com/erlang/otp.git")
+                    (commit (string-append "OTP-" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0gv43lra4870xns8b0yjzbq78afzvz9gk6y3q3fa4y4sqcrqwbas"))
+                "195xq8bmmk0m6f5nkss2gkksyyph3z4wggn8abyicykpc8sdw83d"))
               (patches (search-patches "erlang-man-path.patch"))))
     (build-system gnu-build-system)
     (native-inputs