summary refs log tree commit diff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 22:05:11 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:29 +0200
commite10cdd2c74649b3512f114ddbf1bf3b59c4bf9f3 (patch)
tree15faaaccb93d3618d8fd529f29703f45030acdbe /gnu/packages/erlang.scm
parentf9bd633798bd572f60d52211d27a601cd0874f2b (diff)
downloadguix-e10cdd2c74649b3512f114ddbf1bf3b59c4bf9f3.tar.gz
gnu: Add erlang-getopt.
* gnu/packages/erlang.scm (erlang-getopt): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index f230bb02c5..ca2bfa1683 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -343,3 +343,20 @@ outputs you want to be readable around all that noise they contain.")
     (description "Erlware Commons is an Erlware project focused on all aspects
 of reusable Erlang components.")
     (license license:expat)))
+
+(define-public erlang-getopt
+  (package
+    (name "erlang-getopt")
+    (version "1.0.2")
+    (source
+     (origin
+       (method hexpm-fetch)
+       (uri (hexpm-uri "getopt" version))
+       (sha256
+        (base32 "1yxs36l1ll56zrxn81kw5qd8fv1q14myhjylk7dk31palg7jl725"))))
+    (build-system rebar3-build-system)
+    (home-page "https://github.com/jcomellas/getopt")
+    (synopsis "Command-line options parser for Erlang")
+    (description "This package provides an Erlang module to parse command line
+arguments using the GNU getopt syntax.")
+    (license license:bsd-3)))