summary refs log tree commit diff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-20 02:00:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-20 02:04:50 +0100
commit24cc38ec8ed26d5d367dab42dc49174375c39dcd (patch)
treeb56c1df4f8ed65502db473fdf26784d29c4d0aa5 /gnu/packages/file-systems.scm
parenta86a6fb6fcae3fc0e530149a0106ff7a7c4b3679 (diff)
downloadguix-24cc38ec8ed26d5d367dab42dc49174375c39dcd.tar.gz
gnu: bcachefs-tools-static: Remove input labels.
* gnu/packages/file-systems.scm (bcachefs-tools/static)[inputs]:
Remove input labels.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 8c0fff00b7..e334ec020c 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -505,15 +505,14 @@ performance and other characteristics.")
                    (string-append prefix suffix "\n"))
                   ;; …as does installing a now non-existent file.
                   ((".*\\$\\(INSTALL\\).* lib.*") ""))))))))
-     (inputs
-      `(("eudev:static" ,eudev "static")
-        ("keyutils:static" ,keyutils "static")
-        ("libscrypt:static" ,libscrypt "static")
-        ("lz4:static" ,lz4 "static")
-        ("util-linux:static" ,util-linux "static") ; lib{blkid,uuid}
-        ("zlib" ,zlib "static")
-        ("zstd:static" ,zstd "static")
-        ,@(package-inputs bcachefs-tools)))))
+    (inputs (modify-inputs (package-inputs bcachefs-tools)
+              (prepend `(,eudev "static")
+                       `(,keyutils "static")
+                       `(,libscrypt "static")
+                       `(,lz4 "static")
+                       `(,util-linux "static")
+                       `(,zlib "static")
+                       `(,zstd "static"))))))
 
 (define-public bcachefs/static
   (package