summary refs log tree commit diff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-19 00:20:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-19 00:20:36 +0200
commitc483cc2b9f67782d81a180f7cbde7d57791749c9 (patch)
tree5fc9061133f28b55303773c26c0d1cc31432e97c /gnu/packages/file-systems.scm
parent99af7433112669e4d696921053608a3569d31004 (diff)
downloadguix-c483cc2b9f67782d81a180f7cbde7d57791749c9.tar.gz
gnu: python-dropbox: Update to 11.36.0.
* gnu/packages/file-systems.scm (python-dropbox): Update to 11.36.0.
[source]: Add snippet to accept newer versions of python-pytest-runner.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index bc5bb41fb3..fcb650bf40 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2017, 2018, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
@@ -1585,13 +1585,18 @@ compatible directories.")
 (define-public python-dropbox
   (package
     (name "python-dropbox")
-    (version "11.33.0")
+    (version "11.36.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "dropbox" version))
         (sha256
-         (base32 "1hd9gprvcr6h0p8fxhynf97qf6799whfpsmr73g619392598nqvw"))))
+         (base32 "0iwbi1qdw9qr7isa37yys582am59k80dqrwvm6s0afdwv0ifa343"))
+        (snippet
+         '(begin
+            (use-modules (guix build utils))
+            (substitute* "setup.py"
+              (("pytest-runner == 5\\.2\\.0") "pytest-runner"))))))
     (build-system python-build-system)
     (arguments '(#:tests? #f))  ; Tests require a network connection.
     (native-inputs