summary refs log tree commit diff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-13 17:51:27 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-13 17:51:27 +0100
commit310081e27ec5f9422f7d48a9b466af9d155747c4 (patch)
tree7254d15de81847dbfed953be3741ce85b971f318 /gnu/packages/file.scm
parenta480307449fa949ac5624c98e573b28fc3d70a9f (diff)
downloadguix-310081e27ec5f9422f7d48a9b466af9d155747c4.tar.gz
gnu: file: Remove replacement; add separate file-5.20 package.
* gnu/packages/file.scm (file)[replacement]: Remove.
  (file/fixed): Remove.
  (file-5.20): New variable.
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 0b4cae98ba..a90ab9c98e 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -26,7 +26,6 @@
 
 (define-public file
   (package
-   (replacement file/fixed)
    (name "file")
    (version "5.19")
    (source (origin
@@ -46,14 +45,13 @@ of the file.")
    (license bsd-2)
    (home-page "http://www.darwinsys.com/file/")))
 
-(define file/fixed                                ;fix for CVE-2014-3710
-  (let ((real-version "5.20"))
-    (package (inherit file)
-      (source (origin
-                (method url-fetch)
-                (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
-                                    real-version ".tar.gz"))
-                (sha256
-                 (base32
-                  "0iyjs9z8kp43gz7gva4j67h4p0n53f7q8x3ibai9s01sp3xnphsv"))))
-      (replacement #f))))
+(define-public file-5.20                          ;fix for CVE-2014-3710
+  (package (inherit file)
+    (version "5.20")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0iyjs9z8kp43gz7gva4j67h4p0n53f7q8x3ibai9s01sp3xnphsv"))))))