summary refs log tree commit diff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-05-20 09:01:18 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-05-20 09:01:18 +0200
commit24b6f94cf9b4ab97ef2eb70d05b2104a06776e62 (patch)
tree31996d93a642e37b83650646c651bcc4938976dd /gnu/packages/finance.scm
parent0aab24855238cc7c7a31066ab39cd94e534b857f (diff)
downloadguix-24b6f94cf9b4ab97ef2eb70d05b2104a06776e62.tar.gz
gnu: bitcoin-core-24.1: Rename to bitcoin-core.
* gnu/packages/finance.scm (bitcoin-core): Remove variable.
  (bitcoin-core-24.1): Rename to bitcoin-core.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index c5bdb8a253..559b22257b 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -134,7 +134,9 @@
   #:use-module (gnu packages xml)
   #:use-module (gnu packages gnuzilla))
 
-(define-public bitcoin-core-24.1
+(define-public bitcoin-core
+  ;; The support lifetimes for bitcoin-core versions can be found in
+  ;; <https://bitcoincore.org/en/lifecycle/#schedule>.
   (package
     (name "bitcoin-core")
     (version "24.1")
@@ -213,11 +215,6 @@ of the bitcoin protocol.  This package provides the Bitcoin Core command
 line client and a client based on Qt.")
     (license license:expat)))
 
-;; The support lifetimes for bitcoin-core versions can be found in
-;; <https://bitcoincore.org/en/lifecycle/#schedule>.
-
-(define-public bitcoin-core bitcoin-core-24.1)
-
 (define-public ghc-hledger
   (package
     (name "ghc-hledger")