summary refs log tree commit diff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2023-02-28 02:21:54 +0100
committerJelle Licht <jlicht@fsfe.org>2023-03-06 14:58:57 +0100
commit6494f93e21a230ff44a62ca0fe642737537858fe (patch)
tree3e13d77ea552967bee21baa1b44d4a2a15cecc93 /gnu/packages/finance.scm
parentfe9bcf9db24e6f7849ad870e0853c251517fd6f0 (diff)
downloadguix-6494f93e21a230ff44a62ca0fe642737537858fe.tar.gz
gnu: ledger: Update to 3.3.1.
* gnu/packages/finance.scm (ledger): Update to 3.3.1.
[source]: Remove snippet.
[arguments]<#:phases>: Re-enable old test.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 8e1c8fd568..3f3fc078f0 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -311,7 +311,7 @@ and dynamically with report tools based on filtering and graphical charts.")
 (define-public ledger
   (package
     (name "ledger")
-    (version "3.2.1")
+    (version "3.3.1")
     (source
      (origin
        (method git-fetch)
@@ -320,14 +320,7 @@ and dynamically with report tools based on filtering and graphical charts.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0x6jxwss3wwzbzlwmnwb8yzjk8f9wfawif4f1b74z2qg6hc4r7f6"))
-       (snippet '(begin
-                   ;; Remove test that fails due to difference in
-                   ;; reported error message (missing leading "./" in the
-                   ;; file name); started some time after Guix commit
-                   ;; 727f05e1e285aa52f5a19ec923fdc2259859b4b1
-                   (delete-file "test/regress/BF3C1F82-2.test")
-                   #true))))
+        (base32 "13bbnfb08ymm54wg12dapqhalh7iialfs66qdbk2adl1aaq36wqa"))))
     (build-system cmake-build-system)
     (arguments
      `(#:modules (,@%cmake-build-system-modules
@@ -369,10 +362,6 @@ and dynamically with report tools based on filtering and graphical charts.")
              (setenv "TZDIR"
                      (search-input-directory inputs
                                              "share/zoneinfo"))
-             ;; Skip failing test BaselineTest_cmd-org.
-             ;; This is a known upstream issue. See
-             ;; https://github.com/ledger/ledger/issues/550
-             (setenv "ARGS" "-E BaselineTest_cmd-org")
              #t)))))
     (inputs
      (list boost