summary refs log tree commit diff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-31 14:21:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-31 14:21:48 +0100
commit61c002930e8668928aa48c6a8e73cc156648a23e (patch)
treec7b173c7e5f9e38f7877f9743be0fec659589cfc /gnu/packages/finance.scm
parent0f902e6a9e2d1e7045521c12e000c601f6a2742d (diff)
downloadguix-61c002930e8668928aa48c6a8e73cc156648a23e.tar.gz
gnu: silkaj: Update to 0.10.0.
* gnu/packages/finance.scm (silkaj): Update to 0.10.0.
[build-system]: Use PYPROJECT-BUILD-SYSTEM.
[arguments]: Remove it.
[native-inputs]: Add PYTHON-POETRY-CORE.
[inputs]: Remove input labels. Remove PYTHON-PYNACL. Add PYTHON-PENDULUM.
[description]: Do not overemphasize project name.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index ac19851a85..d401a04f45 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
-;;; Copyright © 2018, 2019, 2020, 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
@@ -59,6 +59,7 @@
   #:use-module (guix build-system emacs)
   #:use-module (guix build-system haskell)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system go)
   #:use-module (guix build-system qt)
@@ -1330,25 +1331,25 @@ main features are:
 (define-public silkaj
   (package
     (name "silkaj")
-    (version "0.7.6")
+    (version "0.10.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "silkaj" version))
        (sha256
-        (base32 "0hrn0jwg415z7wjkp0myvw85wszlfi18f56j03075xxakr4dmi2j"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:tests? #f))                    ;no test
-    (inputs
-     `(("click" ,python-click)
-       ("duniterpy" ,python-duniterpy)
-       ("pynacl" ,python-pynacl)
-       ("tabulate" ,python-tabulate)
-       ("texttable" ,python-texttable)))
+        (base32 "0p8jqnswrrxri8i2ikdz8mij7gks0yab3wdcb37jf2kjwmrwanpk"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-poetry-core))
+    (propagated-inputs
+     (list python-click
+           python-duniterpy
+           python-pendulum
+           python-tabulate
+           python-texttable))
     (home-page "https://git.duniter.org/clients/python/silkaj")
     (synopsis "Command line client for Duniter network")
-    (description "@code{Silkaj} is a command line client for the
+    (description "Silkaj is a command line client for the
 @uref{https://github.com/duniter/duniter/, Duniter} network.
 
 Its features are: