summary refs log tree commit diff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-12-28 22:15:34 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-28 22:16:11 +0100
commitd6ddeffcbcf0ba1b82557da470004b050999762b (patch)
treec487cfef46ccc1f1beef02674fe0a10cd094acef /gnu/packages/finance.scm
parent65f88296fbf2dcebf44c0fcbcf4217c43eca357f (diff)
downloadguix-d6ddeffcbcf0ba1b82557da470004b050999762b.tar.gz
gnu: Add python-keepkey.
* gnu/packages/finance.scm (python-keepkey, python2-keepkey): New variables.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 8da5bf58f0..5284460bfe 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -615,6 +615,40 @@ TREZOR Hardware Wallet.")
 (define-public python2-trezor
   (package-with-python2 python-trezor))
 
+(define-public python-keepkey
+  (package
+    (name "python-keepkey")
+    (version "4.0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "keepkey" version))
+        (sha256
+          (base32
+            "0f4iqqjlqmamw4mhyhik4qlb5bnfd10wbjw9yzgir105wh5fdpnd"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'check)
+         (add-after 'install 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (apply invoke "python" (find-files "tests/unit" "\\.py$")))))))
+    (propagated-inputs
+     `(("python-ecdsa" ,python-ecdsa)
+       ("python-hidapi" ,python-hidapi)
+       ("python-mnemonic" ,python-mnemonic)
+       ("python-protobuf" ,python-protobuf)))
+    (home-page "https://github.com/keepkey/python-keepkey")
+    (synopsis "Python library for communicating with KeepKey Hardware Wallet")
+    (description "@code{keepkey} is a Python library for communicating with
+the KeepKey Hardware Wallet.")
+    (license license:lgpl3)))
+
+(define-public python2-keepkey
+  (package-with-python2 python-keepkey))
+
 (define-public ledger-agent
   (package
     (name "ledger-agent")