summary refs log tree commit diff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorCarlo Holl <carloholl@gmail.com>2020-11-25 12:16:37 -0800
committerLeo Famulari <leo@famulari.name>2020-11-25 21:02:16 -0500
commit1b12261573ac806874052ea747893d1ce9d11f91 (patch)
treea8e1614d9d34d6e0acd3b9136e5dd1794cc74c1e /gnu/packages/finance.scm
parent1112b916a512c39e1fdec1f074c6da297563acfb (diff)
downloadguix-1b12261573ac806874052ea747893d1ce9d11f91.tar.gz
gnu: hledger: Downgrade to 1.14.2.
* gnu/packages/finance.scm (hledger): Downgrade to 0.14.2.
[inputs, native-inputs]: Replace with what is generated by guix import.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7ef40f544f..dc62892e2a 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -186,7 +186,7 @@ line client and a client based on Qt.")
 (define-public hledger
   (package
     (name "hledger")
-    (version "1.19.1")
+    (version "1.14.2")
     (source
      (origin
        (method url-fetch)
@@ -196,22 +196,22 @@ line client and a client based on Qt.")
              ".tar.gz"))
        (sha256
         (base32
-         "0wfsyf2q1kf90mj3lxs0m5ghj153axmpkc8xfy12vkz5imnyphfm"))))
+         "1si9zqparkdq77yji87lhcsrf11fr3gisqwsv82cabhrhc36x6l4"))))
     (build-system haskell-build-system)
     (inputs
-     `(("ghc-decimal" ,ghc-decimal)
-       ("ghc-diff" ,ghc-diff)
-       ("ghc-aeson" ,ghc-aeson)
-       ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+     `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
        ("ghc-base-compat-batteries" ,ghc-base-compat-batteries)
        ("ghc-cmdargs" ,ghc-cmdargs)
        ("ghc-data-default" ,ghc-data-default)
-       ("ghc-extra" ,ghc-extra)
+       ("ghc-decimal" ,ghc-decimal)
+       ("ghc-diff" ,ghc-diff)
+       ("ghc-easytest" ,ghc-easytest)
        ("ghc-hashable" ,ghc-hashable)
        ("ghc-hledger-lib" ,ghc-hledger-lib)
        ("ghc-lucid" ,ghc-lucid)
        ("ghc-math-functions" ,ghc-math-functions)
        ("ghc-megaparsec" ,ghc-megaparsec)
+       ("ghc-mtl-compat" ,ghc-mtl-compat)
        ("ghc-old-time" ,ghc-old-time)
        ("ghc-pretty-show" ,ghc-pretty-show)
        ("ghc-regex-tdfa" ,ghc-regex-tdfa)
@@ -219,13 +219,14 @@ line client and a client based on Qt.")
        ("ghc-shakespeare" ,ghc-shakespeare)
        ("ghc-split" ,ghc-split)
        ("ghc-tabular" ,ghc-tabular)
-       ("ghc-tasty" ,ghc-tasty)
        ("ghc-temporary" ,ghc-temporary)
-       ("ghc-timeit" ,ghc-timeit)
        ("ghc-unordered-containers" ,ghc-unordered-containers)
        ("ghc-utf8-string" ,ghc-utf8-string)
        ("ghc-utility-ht" ,ghc-utility-ht)
        ("ghc-wizards" ,ghc-wizards)))
+    (native-inputs
+     `(("ghc-test-framework" ,ghc-test-framework)
+       ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
     (home-page "https://hledger.org")
     (synopsis "Command-line interface for the hledger accounting system")
     (description