summary refs log tree commit diff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-18 21:23:36 +0100
committerMarius Bakke <marius@gnu.org>2021-12-23 03:07:34 +0100
commite839bbc880c3c961f57b8693fbb2ccf1a82db711 (patch)
treed0666c651e6370469485629c330197aca3b60d46 /gnu/packages/firmware.scm
parent91918e94056c17aca2217db611e69265b8b7c8b9 (diff)
downloadguix-e839bbc880c3c961f57b8693fbb2ccf1a82db711.tar.gz
gnu: seabios: Update to 1.15.0.
* gnu/packages/firmware.scm (seabios): Update to 1.15.0.
[arguments]: Remove trailing #t's.
[native-inputs]: Remove label.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 1dc64a5341..cf6fa73be8 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -281,7 +281,7 @@ for platform-specific firmwares executing in M-mode.")
 (define-public seabios
   (package
     (name "seabios")
-    (version "1.14.0")
+    (version "1.15.0")
     (source
      (origin
        (method git-fetch)
@@ -290,25 +290,22 @@ for platform-specific firmwares executing in M-mode.")
              (commit (string-append "rel-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0jp4rxsv9jdzvx4gjvkybj6g1yjg8pkd2wys4sdh6c029npp6y8p"))))
+        (base32 "0gnsfmbgcvihsap8sz8c2n3qs439q44i3pwrms2nv3xcnf1sclj9"))))
     (build-system gnu-build-system)
-    (native-inputs
-     `(("python" ,python-wrapper)))
+    (native-inputs (list python-wrapper))
     (arguments
      `(#:tests? #f                      ; no check target
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
            (lambda _
-             (setenv "CC" "gcc")
-             #t))
+             (setenv "CC" "gcc")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (fmw (string-append out "/share/firmware")))
                (mkdir-p fmw)
-               (copy-file "out/bios.bin" (string-append fmw "/bios.bin"))
-               #t))))))
+               (copy-file "out/bios.bin" (string-append fmw "/bios.bin"))))))))
     (home-page "https://www.seabios.org/SeaBIOS")
     (synopsis "x86 BIOS implementation")
     (description "SeaBIOS is an implementation of a 16bit x86 BIOS.  SeaBIOS