summary refs log tree commit diff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-22 13:50:30 +0100
committerMarius Bakke <marius@gnu.org>2022-12-22 16:50:47 +0100
commit209aed9511f41b2bfabe32d2e280192e64e3d54b (patch)
tree34cd3bfce5d96cf2354fcb08dedb72d5ee644c6b /gnu/packages/firmware.scm
parentba7f6f0bf3922968d16ad433da818928381e1578 (diff)
downloadguix-209aed9511f41b2bfabe32d2e280192e64e3d54b.tar.gz
gnu: Install QEMU firmare files to 'share/qemu'.
This paves the way for using a native search path in the future.

* gnu/packages/bootloaders.scm (ipxe-qemu)[arguments]: Install firmware files
to 'share/qemu' instead of 'share/firmware'.
* gnu/packages/firmware.scm (seabios-qemu)[arguments]: Likewise.
* gnu/packages/virtualization.scm (qemu)[arguments]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 03c84fbe88..eac3176d72 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -560,7 +560,7 @@ coreboot.")
                                 vgabiosen))))))
             (replace 'install
               (lambda _
-                (let ((firmware (string-append #$output "/share/firmware")))
+                (let ((firmware (string-append #$output "/share/qemu")))
                   (for-each (lambda (bios)
                               (install-file bios firmware))
                             (find-files "out" "\\.bin$"))