summary refs log tree commit diff
path: root/gnu/packages/fish.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-07-10 08:07:00 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-07-11 08:11:07 -0400
commit361046f7ebd473a0363243a141dc6ed4cfd0d7b9 (patch)
tree3ca5aa67dbcd9a59d5ed5e0c227599f9dc86ad34 /gnu/packages/fish.scm
parent715956cc26a4c04dc4b02c81848851d5a7ace832 (diff)
downloadguix-361046f7ebd473a0363243a141dc6ed4cfd0d7b9.tar.gz
gnu: Add fish.
* gnu/packages/fish.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/fish.scm')
-rw-r--r--gnu/packages/fish.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/fish.scm b/gnu/packages/fish.scm
new file mode 100644
index 0000000000..5833e7b75b
--- /dev/null
+++ b/gnu/packages/fish.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fish)
+  #:use-module (guix licenses)
+  #:use-module (gnu packages doxygen)
+  #:use-module (gnu packages ncurses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix utils)
+  #:use-module (guix build-system gnu))
+
+(define-public fish
+  (package
+    (name "fish")
+    (version "2.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://fishshell.com/files/"
+                                  version "/fish-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0i7h3hx8iszli3d4kphw79sz9m07f2lc2c9hr9smdps5s7wpllmg"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("doxygen" ,doxygen)))
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (arguments
+     '(#:tests? #f)) ; no check target
+    (synopsis "The friendly interactive shell")
+    (description
+     "Fish (friendly interactive shell) is a shell focused on interactive use,
+discoverability, and friendliness.  Fish has very user-friendly and powerful
+tab-completion, including descriptions of every completion, completion of
+strings with wildcards, and many completions for specific commands.  It also
+has extensive and discoverable help.  A special help command gives access to
+all the fish documentation in your web browser. Other features include smart
+terminal handling based on terminfo, an easy to search history, and syntax
+highlighting. ")
+    (home-page "http://fishshell.com/")
+    (license gpl2)))