summary refs log tree commit diff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
committerMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
commit1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f (patch)
tree4b650999e49a6f4d3dd116fab3f9ee8222247e07 /gnu/packages/flashing-tools.scm
parentaa27987f71cb8afa698ede551e20b1248f160113 (diff)
parent50c7a1e297bff0935674b4f30e854a8889becfdd (diff)
downloadguix-1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 648430ad5a..194ed380bb 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -108,7 +108,7 @@ technique (ISP).")
 (define-public dfu-programmer
   (package
     (name "dfu-programmer")
-    (version "0.7.0")
+    (version "0.7.2")
     (source
      (origin
       (method url-fetch)
@@ -116,14 +116,17 @@ technique (ISP).")
                           version ".tar.gz"))
       (sha256
        (base32
-        "17lglglk5xrqd2n0impg5bkq4j96qc51cw3kzcghzmzmn6fvg3gf"))
+        "15gr99y1z9vbvhrkd25zqhnzhg6zjmaam3vfjzf2mazd39mx7d0x"))
       (patches (list (search-patch "dfu-programmer-fix-libusb.patch")))))
     (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (inputs
      `(("libusb" ,libusb)))
     (home-page "http://dfu-programmer.github.io/")
     (synopsis "Device firmware update programmer for Atmel chips")
     (description
-     "Dfu-programmer is a multi-platform command-line programmer for Atmel
-(8051, AVR, XMEGA & AVR32) chips with a USB bootloader supporting ISP")
+     "Dfu-programmer is a multi-platform command-line programmer for
+Atmel (8051, AVR, XMEGA & AVR32) chips with a USB bootloader supporting
+ISP.")
     (license gpl2+)))