summary refs log tree commit diff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-02-13 19:01:43 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-02-15 12:05:24 +0100
commit501e18471610ba9942567ce8c2d4ad40182bd141 (patch)
treec41eb71702e960aa6883dccdbb5e41d0fdedfcf5 /gnu/packages/flashing-tools.scm
parent5a9902c8acd63916c6c80cf3c61be6ee814b7e3d (diff)
downloadguix-501e18471610ba9942567ce8c2d4ad40182bd141.tar.gz
gnu: Add ifdtool.
* gnu/packages/flashing-tools.scm (ifdtool): New variable.
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 9683c6b4a3..2a89b6ab0a 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -330,3 +330,36 @@ USB and interacts with low-level software running on the device, known as Loke.
 Loke and Heimdall communicate via the custom Samsung-developed protocol typically
 referred to as the \"Odin 3 protocol\".")
     (license license:expat)))
+
+(define-public ifdtool
+  (package
+    (name "ifdtool")
+    (version "4.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://review.coreboot.org/p/coreboot")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0nw555i0fm5kljha9h47bk70ykbwv8ddfk6qhz6kfqb79vzhy4h2"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list "CC=gcc"
+             "INSTALL=install"
+             (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+        (add-after 'unpack 'chdir
+          (lambda _
+            (chdir "util/ifdtool")
+            #t))
+        (delete 'configure)
+        (delete 'check))))
+    (home-page "https://github.com/corna/me_cleaner/")
+    (synopsis "Intel Firmware Descriptor dumper")
+    (description "This package provides @ifdtool}, a program to
+dump Intel Firmware Descriptor data of an image file.")
+    (license license:gpl2)))