summary refs log tree commit diff
path: root/gnu/packages/flex.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-29 21:44:39 -0400
committerLeo Famulari <leo@famulari.name>2016-10-29 21:44:44 -0400
commit062c7e43ed306c66f1107ee3bd52357aa8daf11a (patch)
treef620ea2436a9809d7e4113fa3c9704c5f7892c8e /gnu/packages/flex.scm
parentf4fe6c991cbac609be327ad8ed793c5b1b91aac8 (diff)
parent269d9172ff037bd41bee3777166b3bc14d93f745 (diff)
downloadguix-062c7e43ed306c66f1107ee3bd52357aa8daf11a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/flex.scm')
-rw-r--r--gnu/packages/flex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index c2135a1bc0..c1f74d65ad 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -79,3 +79,22 @@ regular expressions for each rule.  Whenever it finds a match, it
 executes the corresponding C code.")
     (license (non-copyleft "file://COPYING"
                         "See COPYING in the distribution."))))
+
+(define-public flex-2.6.1
+  ;; The kservice and solid packages use flex.  extra-cmake-modules
+  ;; forces C89 for all C files for compatibility with windows.
+  ;; Flex 2.6.0 generates a lexer containing a single line comment.  Single
+  ;; line comments are part of the C99 standard, so the lexer won't compile
+  ;; if C89 is used.
+  (package
+    (inherit flex)
+    (version "2.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/westes/flex"
+                    "/releases/download/v" version "/"
+                    "flex-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0fy14c35yz2m1n1m4f02by3501fn0cca37zn7jp8lpp4b3kgjhrw"))))))