summary refs log tree commit diff
path: root/gnu/packages/fltk.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-22 11:39:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-22 11:40:27 +0200
commite10a15fa5fef5bdcb1cf202e5472ed9a55009d0b (patch)
tree9e4b24c0b1ab3f56d21813f66c409cf37dab3db8 /gnu/packages/fltk.scm
parentc57e50b2b9800ce53f7ff9b7b81bb862897a9a2c (diff)
downloadguix-e10a15fa5fef5bdcb1cf202e5472ed9a55009d0b.tar.gz
gnu: ntk: Update to 1.3.1000.
* gnu/packages/fltk.scm (ntk): Update to 1.3.1000.
[arguments]: Do not use python-2; add missing #t to "set-ldflags" phase.
Diffstat (limited to 'gnu/packages/fltk.scm')
-rw-r--r--gnu/packages/fltk.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/fltk.scm b/gnu/packages/fltk.scm
index af7186ab7f..e4eb2fcad0 100644
--- a/gnu/packages/fltk.scm
+++ b/gnu/packages/fltk.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
 ;;;
@@ -99,7 +99,7 @@ UI builder called FLUID that can be used to create applications in minutes.")
 (define-public ntk
   (package
     (name "ntk")
-    (version "1.3.0")
+    (version "1.3.1000")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -107,21 +107,20 @@ UI builder called FLUID that can be used to create applications in minutes.")
                     (commit (string-append "v" version))))
               (sha256
                (base32
-                "0ggrh6rihf676z1vfgpgcl6kpqwyh39ih0hskcgzklh7fphfik39"))
+                "0j38mhnfqy6swcrnc5zxcwlqi8b1pgklyghxk6qs1lf4japv2zc0"))
               (file-name (string-append name "-" version "-checkout"))))
     (build-system waf-build-system)
     (arguments
      `(#:tests? #f ;no "check" target
-       #:python ,python-2
        #:configure-flags '("--enable-gl")
        #:phases
        (modify-phases %standard-phases
-         (add-before
-          'configure 'set-ldflags
-          (lambda* (#:key outputs #:allow-other-keys)
-            (setenv "LDFLAGS"
-                    (string-append "-Wl,-rpath="
-                                   (assoc-ref outputs "out") "/lib")))))))
+         (add-before 'configure 'set-ldflags
+           (lambda* (#:key outputs #:allow-other-keys)
+             (setenv "LDFLAGS"
+                     (string-append "-Wl,-rpath="
+                                    (assoc-ref outputs "out") "/lib"))
+             #t)))))
     (inputs
      `(("libjpeg" ,libjpeg)
        ("glu" ,glu)))