summary refs log tree commit diff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-02-03 07:43:12 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:33 +0200
commit13e9e6d215c6aca7c517bc5069fc7fa03caba7c7 (patch)
treee263e7528713ab52a24651c9103b57bd8ac3beb1 /gnu/packages/fonts.scm
parent6bb9888273dba67056a135566c2368758988ebb7 (diff)
downloadguix-13e9e6d215c6aca7c517bc5069fc7fa03caba7c7.tar.gz
gnu: font-dseg: Simplify "install" phase.
* gnu/packages/fonts.scm (font-dseg)[source]: Use url-fetch.
[arguments]<#:phases>: Remove "with-directory-excursion" from "install" phase.
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index ae03fd6b30..30d852e06b 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2657,7 +2657,7 @@ have been designed to be very distinguishable from each other.")
     (version "0.46")
     (source
       (origin
-        (method url-fetch/zipbomb)
+        (method url-fetch)
         (uri
           (string-append "https://github.com/keshikan/DSEG/"
                          "releases/download/v" version
@@ -2675,13 +2675,9 @@ have been designed to be very distinguishable from each other.")
              (let* ((out (assoc-ref outputs "out"))
                     (font-dir (string-append out "/share/fonts"))
                     (truetype-dir (string-append font-dir "/truetype")))
-               (with-directory-excursion
-                 (string-append "fonts-DSEG_v"
-                                (apply string-append (string-split ,version
-                                                                   #\.)))
-                 (for-each (lambda (f) (install-file f truetype-dir))
-                           (find-files "." "\\.ttf$"))
-               #t)))))))
+               (for-each (lambda (f) (install-file f truetype-dir))
+                         (find-files "." "\\.ttf$"))
+               #t))))))
     (home-page "https://www.keshikan.net/fonts-e.html")
     (synopsis "DSEG: 7-segment and 14-segment fonts")
     (description