summary refs log tree commit diff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorLuis Felipe <sirgazil@zoho.com>2024-01-21 11:47:55 -0500
committerLudovic Courtès <ludo@gnu.org>2024-02-05 22:43:18 +0100
commit28434e496ca76f81f7bca4022912677209c300b7 (patch)
tree7c8cc90e1042abe86b8e38690ba470be7da697f3 /gnu/packages/fonts.scm
parent3d9600ba1281b41307b4257e66dd8e3d6129d19f (diff)
downloadguix-28434e496ca76f81f7bca4022912677209c300b7.tar.gz
gnu: Add font-oswald.
* gnu/packages/fonts.scm (font-oswald): New variable.

Change-Id: Ief63b944b722d5ed1b3cabd041bcd75948a1f59e
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a69e54540b..17eb528371 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -58,7 +58,7 @@
 ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2023 chris <chris@bumblehead.com>
-;;; Copyright © 2023 Luis Felipe López Acevedo <sirgazil@zoho.com>
+;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <sirgazil@zoho.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3521,3 +3521,31 @@ for display purposes.  It features four weights (light, medium, bold,
 and black), a stylistic alternative, small caps, and many alternate
 glyphs.")
       (license license:silofl1.1))))
+
+(define-public font-oswald
+  (let ((version "0")
+        (commit "6e65651c229e897dc55fb8d17097ee7f75b2769b")
+        (revision "0"))
+    (package
+      (name "font-oswald")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/googlefonts/OswaldFont")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0m5c98crw6df6hbhxv4smh6ldzk5fx434fyri8xgnsjjcrkqxy0h"))))
+      (build-system font-build-system)
+      (home-page "https://github.com/googlefonts/OswaldFont")
+      (synopsis "Gothic typeface")
+      (description "Oswald is a reworking of the classic gothic typeface
+style historically represented by designs such as 'Alternate Gothic'.
+The characters of Oswald have been re-drawn and reformed to better fit
+the pixel grid of standard digital screens.  Oswald is designed to be
+used freely across the internet by web browsers on desktop computers,
+laptops and mobile devices.")
+      (license license:silofl1.1))))