summary refs log tree commit diff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorArnaud Lechevallier <arnaud.lechevallier@free.fr>2023-05-08 19:16:30 +0200
committer宋文武 <iyzsong@member.fsf.org>2023-05-14 11:31:48 +0800
commit9c1b9bfef3d1573a690e95aa04af61c40a3c92de (patch)
treee9581387d5128bac2bd81a76965f9c506a890151 /gnu/packages/fonts.scm
parent03af9d56fb99df6a1a1cdbb0018e9e60da7bb74a (diff)
downloadguix-9c1b9bfef3d1573a690e95aa04af61c40a3c92de.tar.gz
gnu: Add Iosevka comfy font.
* gnu/packages/fonts.scm (font-iosevka-comfy): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a0e0002140..e4c53dbc73 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -54,6 +54,7 @@
 ;;; Copyright © 2022 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
+;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1810,6 +1811,25 @@ programming.  Iosevka is completely generated from its source code.")
        (sha256
         (base32 "1h5jfrpply7ypc4h6ivxs30qkrbni51zkj78xz6nz4zbnp923yi0"))))))
 
+(define-public font-iosevka-comfy
+  (package
+    (inherit font-iosevka)
+    (name "font-iosevka-comfy")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~protesilaos/iosevka-comfy")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1gccv28avxlkicl6rcsn6i23pdn0nrk91zhcyzwwc3nyzm2w8w40"))))
+    (home-page "https://git.sr.ht/~protesilaos/iosevka-comfy")
+    (description
+     "Iosevka Comfy is a TTF font derived from Iosevka.  It is a slightly tweaked
+     version of the original, designed for enhanced readability.")
+    (license license:silofl1.1)))
+
 (define-public font-sarasa-gothic
   (package
     (name "font-sarasa-gothic")