summary refs log tree commit diff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2023-01-09 01:05:04 +0000
committer宋文武 <iyzsong@member.fsf.org>2023-01-28 10:54:29 +0800
commitf26c474dec2d3a32e2c5c9f869300faebffbfb01 (patch)
tree181e6a44942d5adb26192b1a7b71db7531d7e1e9 /gnu/packages/fonts.scm
parent3c075ffd82a64e185579aa94e03be020faeebb4f (diff)
downloadguix-f26c474dec2d3a32e2c5c9f869300faebffbfb01.tar.gz
gnu: Add font-google-noto-emoji.
* gnu/packages/fonts.scm (font-google-noto-emoji): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 95e99d5a73..8bf88c403b 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -939,6 +939,37 @@ all languages with a consistent look and aesthetic.  Its goal is to properly
 display all Unicode symbols.")
     (license license:silofl1.1)))
 
+(define-public font-google-noto-emoji
+  (package
+    (name "font-google-noto-emoji")
+    (version "2.038")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/googlefonts/noto-emoji")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1rgmcc6nqq805iqr8kvxxlk5cf50q714xaxk3ld6rjrd69kb8ix9"))))
+    (build-system font-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'remove-unsupported
+            (lambda* _
+              (delete-file "fonts/NotoColorEmoji_WindowsCompatible.ttf")
+              (delete-file "fonts/Noto-COLRv1-noflags.ttf")
+              (delete-file "fonts/Noto-COLRv1.ttf"))))))
+    (home-page "https://fonts.google.com/noto/specimen/Noto+Color+Emoji")
+    (synopsis "Font for rendering color emoji characters")
+    (description
+     "This package provides the color emoji font from the Google Noto font
+family.")
+    (license license:silofl1.1)))
+
 (define-public font-google-noto-sans-cjk
   (package
     (name "font-google-noto-sans-cjk")