summary refs log tree commit diff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-08-30 19:52:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-09-02 08:44:54 +0200
commit3f88152d253cd5c232d46ba2eb73aa3096cfe5d9 (patch)
tree6e5bf9490b9ad0ca1dc3cf021dac780a5c19f076 /gnu/packages/fonts.scm
parentdee38b7b41a7415ac3e43757635f0964508db250 (diff)
downloadguix-3f88152d253cd5c232d46ba2eb73aa3096cfe5d9.tar.gz
gnu: Add TeX Gyre fonts.
* gnu/packages/fonts.scm (font-tex-gyre): New variable.
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 62d44ec26b..a78995c804 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -486,3 +487,40 @@ code-points needed for zh_cn, zh_sg, zh_tw, zh_hk, zh_mo, ja (Japanese) and
 ko (Korean) locales for fontconfig.")
     ;; GPLv2 with font embedding exception
     (license license:gpl2)))
+
+(define-public font-tex-gyre
+  (package
+    (name "font-tex-gyre")
+    (version "2.005")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.gust.org.pl/projects/e-foundry/"
+                           "tex-gyre/whole/tg-" version "otf.zip"))
+       (sha256
+        (base32
+         "0kph9l3g7jb2bpmxdbdg5zl56wacmnvdvsdn7is1gc750sqvsn31"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+
+         (let ((unzip    (string-append (assoc-ref %build-inputs "unzip")
+                                        "/bin/unzip"))
+               (font-dir (string-append %output "/share/fonts/opentype")))
+           (mkdir-p font-dir)
+           (system* unzip
+                    (assoc-ref %build-inputs "source")
+                    "-d" font-dir)))))
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (home-page "http://www.gust.org.pl/projects/e-foundry/tex-gyre/")
+    (synopsis "Remake of Ghostscript fonts")
+    (description "The TeX Gyre collection of fonts is the result of an
+extensive remake and extension of the freely available base PostScript fonts
+distributed with Ghostscript version 4.00.  The collection contains the
+following fonts in the OpenType format: Adventor, Bonum, Chorus, Cursor,
+Heros, Pagella, Schola, Termes.")
+    (license license:gfl1.0)))