summary refs log tree commit diff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authoralírio eyng <alirioeyng@gmail.com>2016-03-24 06:17:04 +0000
committerLudovic Courtès <ludo@gnu.org>2016-04-01 00:05:42 +0200
commit52af45adeb13d5ca4757ad8e2e4388de265b3de3 (patch)
tree25744d1acb919d1b99a8b9311aac17b015d43655 /gnu/packages/fontutils.scm
parent2cdeecbe4da32b4ec8c23c338f11cd16d6eededa (diff)
downloadguix-52af45adeb13d5ca4757ad8e2e4388de265b3de3.tar.gz
gnu: fontforge: Build fonts bit-reproducibly.
* gnu/packages/fontutils.scm (fontforge)[source](snippet): Modify
tottf.c.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 34f391e5fa..ff10a4ac73 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -351,14 +351,20 @@ definitions.")
                      "0gfcm8yn1d30giqhdwbchnfnspcqypqdzrxlhqhwy1i18wgl0v2v"))
             (modules '((guix build utils)))
             (snippet
-             ;; Make builds bit-reproducible by using fixed date strings.
-             '(substitute* "configure"
-                (("^FONTFORGE_MODTIME=.*$")
-                 "FONTFORGE_MODTIME=\"1458399002\"\n")
-                (("^FONTFORGE_MODTIME_STR=.*$")
-                 "FONTFORGE_MODTIME_STR=\"15:50 CET 19-Mar-2016\"\n")
-                (("^FONTFORGE_VERSIONDATE=.*$")
-                 "FONTFORGE_VERSIONDATE=\"20160319\"\n")))))
+             '(begin
+               ;; Make builds bit-reproducible by using fixed date strings.
+               (substitute* "configure"
+                 (("^FONTFORGE_MODTIME=.*$")
+                  "FONTFORGE_MODTIME=\"1458399002\"\n")
+                 (("^FONTFORGE_MODTIME_STR=.*$")
+                  "FONTFORGE_MODTIME_STR=\"15:50 CET 19-Mar-2016\"\n")
+                 (("^FONTFORGE_VERSIONDATE=.*$")
+                  "FONTFORGE_VERSIONDATE=\"20160319\"\n"))
+
+               ;; Make TTF builds bit-reproducible by clearing the timestamp
+               ;; that goes in TTF files.
+               (substitute* "fontforge/tottf.c"
+                 (("cvt_unix_to_1904\\(now") "cvt_unix_to_1904(0"))))))
    (build-system gnu-build-system)
    (native-inputs
     `(("pkg-config" ,pkg-config)))