summary refs log tree commit diff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2022-12-22 12:09:53 -0500
committerLudovic Courtès <ludo@gnu.org>2022-12-27 23:53:41 +0100
commit79240b4b4eb3a3f62130d310660aef87ff43ced4 (patch)
treeed50eb3dbf83ca550c4a2889689f9282aa4ebec9 /gnu/packages/fpga.scm
parentc10238966ef936c294cdfe513c2d9fef7bb0671f (diff)
downloadguix-79240b4b4eb3a3f62130d310660aef87ff43ced4.tar.gz
gnu: abc: Use gexps.
* gnu/packages/fpga.scm (abc)[arguments]: Use gexps; simplify "install" phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 8784ba9c12..9bc387c762 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -84,16 +84,14 @@
     (inputs
      (list readline))
     (arguments
-     `(#:license-file-regexp "copyright.txt"
-       #:tests? #f ; no check target
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (out-bin (string-append out "/bin")))
-               (install-file "abc" out-bin)))))))
+     (list #:license-file-regexp "copyright.txt"
+           #:tests? #f ; no check target
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)
+               (replace 'install
+                 (lambda _
+                   (install-file "abc" (string-append #$output "/bin")))))))
     (home-page "https://people.eecs.berkeley.edu/~alanmi/abc/")
     (synopsis "Sequential logic synthesis and formal verification")
     (description "ABC is a program for sequential logic synthesis and