summary refs log tree commit diff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-02-20 22:37:48 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-02-20 22:45:33 +0100
commitec299312a03ca7e2d97c7426b8f9bcb4983f4254 (patch)
tree757e55b4a14ac79dcfc78fe449ef5cc7bbd61d64 /gnu/packages/fpga.scm
parentfb36ac61d4c107c8eedf9b2b29ef62c24f95b472 (diff)
downloadguix-ec299312a03ca7e2d97c7426b8f9bcb4983f4254.tar.gz
gnu: fpga.scm: Use git-version and git-file-name where appropriate.
* gnu/packages/fpga.scm (abc): Use git-version. The uri is using an
  autogenerated commit package, it would ideally use git-fetch. The
  canonical repository is now on GitHub, but the old commit ID is not
  present. This means that changing the origin is best done together
  with an update.
  (icestorm): Use git-version, git-file-name.
  (arachne-pnr): Use git-file-name.
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 129b41f99a..dca67ad3ca 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -51,15 +51,15 @@
        (revision "1"))
   (package
     (name "abc")
-    (version (string-append "0.0-" revision "-" (string-take commit 9)))
+    (version (git-version "0.0" revision commit))
     (source (origin
               (method url-fetch)
               (uri
                (string-append "https://bitbucket.org/alanmi/abc/get/" commit ".zip"))
               (file-name (string-append name "-" version "-checkout.zip"))
               (sha256
-                (base32
-                   "1syygi1x40rdryih3galr4q8yg1w5bvdzl75hd27v1xq0l5bz3d0"))))
+               (base32
+                "1syygi1x40rdryih3galr4q8yg1w5bvdzl75hd27v1xq0l5bz3d0"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("unzip" ,unzip)))
@@ -216,13 +216,13 @@ For synthesis, the compiler generates netlists in the desired format.")
         (revision "2"))
    (package
     (name "icestorm")
-    (version (string-append "0.0-" revision "-" (string-take commit 9)))
+    (version (git-version "0.0" revision commit))
     (source (origin
               (method git-fetch)
               (uri (git-reference
                      (url "https://github.com/cliffordwolf/icestorm.git")
                      (commit commit)))
-              (file-name (string-append name "-" version "-checkout"))
+              (file-name (git-file-name name version))
               (sha256
                 (base32
                    "0bqm0rpywm64yvbq75klpyzb1g9sdsp1kvdlyqg4hvm8jw9w8lya"))))
@@ -267,7 +267,7 @@ Includes the actual FTDI connector.")
               (uri (git-reference
                      (url "https://github.com/YosysHQ/arachne-pnr.git")
                      (commit commit)))
-              (file-name (string-append name "-" version "-checkout"))
+              (file-name (git-file-name name version))
               (sha256
                 (base32
                    "1dqvjvgvsridybishv4pnigw9gypxh7r7nrqp9z9qq92v7c5rxzl"))))