summary refs log tree commit diff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
commit99f63f011df2aab38e98d7ee4608a8c70bf74c4d (patch)
tree3f224028f30c60f2ed7b9846365ad926192fc7e9 /gnu/packages/fpga.scm
parente9a8b603337802a77ff2d68f0d30dc0e67721e3a (diff)
parent4f03aa23e805bd653de774e1d74ed2f50826899b (diff)
downloadguix-99f63f011df2aab38e98d7ee4608a8c70bf74c4d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index c9454aa324..9ab2e35255 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -121,14 +121,15 @@ For synthesis, the compiler generates netlists in the desired format.")
     (name "yosys")
     (version "0.7")
     (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://github.com/cliffordwolf/yosys/archive/"
-                              name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/cliffordwolf/yosys.git")
+                    (commit (string-append "yosys-" version))
+                    (recursive? #t))) ; for the ‘iverilog’ submodule
               (sha256
                 (base32
-                   "0vkfdn4phvkjqlnpqlr6q5f97bgjc3312vj5jf0vf85zqv88dy9x"))
-              (file-name (string-append name "-" version "-checkout.tar.gz"))
+                   "1ssrpgw0j9qlm52g1hsbb9fsww4vnwi0l7zvvky7a8w7wamddky0"))
+              (file-name (git-file-name name version))
               (modules '((guix build utils)))
               (snippet
                '(begin