summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2022-09-18 19:34:40 +0000
committerRicardo Wurmus <rekado@elephly.net>2022-10-08 10:10:06 +0200
commita868595ebb17c16ca6a06d88fc6adca790377540 (patch)
treebac4fc9f9eec3167a930dd08238410e5c7cfbfe1 /gnu/packages/freedesktop.scm
parent0b07c6febb323ed35f5ccae0295a733ae318e6d7 (diff)
downloadguix-a868595ebb17c16ca6a06d88fc6adca790377540.tar.gz
gnu: weston: Update to 10.0.2.
* gnu/packages/freedesktop.scm (weston): Update to 10.0.2.
[inputs] Switch from pipewire to pipewire-0.3, use wayland-protocols-next.
[native-inputs]: Add python-3.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c7339eb00e..4a9cf3229c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1165,18 +1165,18 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
 (define-public weston
   (package
     (name "weston")
-    (version "9.0.0")
+    (version "10.0.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "https://wayland.freedesktop.org/releases/"
-                    "weston-" version ".tar.xz"))
+                    "https://gitlab.freedesktop.org/wayland/weston/-/releases/"
+                    version "/downloads/weston-" version ".tar.xz"))
               (sha256
                (base32
-                "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
+                "1rs92p7sfkw9lqlkfnqh5af19ym3x8l3hp3yfv117m7qv6h6qr49"))))
     (build-system meson-build-system)
     (native-inputs
-     (list mscgen pkg-config xorg-server))
+     (list mscgen pkg-config python-3 xorg-server))
     (inputs
      `(("cairo" ,cairo-xcb)
        ("colord" ,colord)
@@ -1203,8 +1203,8 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
        ("mtdev" ,mtdev)
        ("linux-pam" ,linux-pam)
        ("pango" ,pango)
-       ("pipewire" ,pipewire)
-       ("wayland-protocols" ,wayland-protocols)
+       ("pipewire" ,pipewire-0.3)
+       ("wayland-protocols" ,wayland-protocols-next)
        ("xorg-server-xwayland" ,xorg-server-xwayland)))
     (propagated-inputs
      (list libxkbcommon pixman wayland))