summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:18 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:10 +0200
commitb51b96dc60f46d4c6d9796bec9641ab8212775b4 (patch)
treed1a31ffb1af2ec6e136aa577a2f91d3d21d49942 /gnu/packages/freedesktop.scm
parent1eba27f29a7e40ee7fd5ad1889e413236731847d (diff)
downloadguix-b51b96dc60f46d4c6d9796bec9641ab8212775b4.tar.gz
gnu: udisks: Drop docbook workaround.
XML_CATALOG_FILES is already set by xsltproc.

* gnu/packages/freedesktop.scm (udisks)[arguments]<#:make-flags>: Remove.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 0 insertions, 14 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 31b6f66e1a..3cc5a6f33c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1774,20 +1774,6 @@ Analysis and Reporting Technology) functionality.")
               (string-append "--with-html-dir=" #$output:doc
                              "/share/doc/udisks/html")
               (string-append "--with-udevdir=" #$output "/lib/udev"))
-      #:make-flags
-      #~(let* ((docbook-xsl-name-version
-                #$(string-append (package-name docbook-xsl) "-"
-                                 (package-version docbook-xsl)))
-               (docbook-xsl-catalog-file
-                (string-append #$(this-package-native-input "docbook-xsl")
-                               "/xml/xsl/" docbook-xsl-name-version
-                               "/catalog.xml"))
-               (docbook-xml-catalog-file
-                #$(file-append (this-package-native-input "docbook-xml")
-                               "/xml/dtd/docbook/catalog.xml")))
-          ;; Reference the catalog files required to build the manpages.
-          (list (string-append "XML_CATALOG_FILES=" docbook-xsl-catalog-file
-                               " " docbook-xml-catalog-file)))
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'configure 'fix-girdir