summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-18 10:39:18 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:11 +0100
commitb2b88471d6c3ca08115d5e8079cccad2b7f92369 (patch)
treec527c663cbdfaf94793b353bdb08a9497b908397 /gnu/packages/freedesktop.scm
parentf17f1e1f71fbc8b645f5ffe70600e4a51adb52b0 (diff)
downloadguix-b2b88471d6c3ca08115d5e8079cccad2b7f92369.tar.gz
gnu: packagekit: Remove input labels and use gexp.
* gnu/packages/freedesktop.scm (pacakgekit): Remove input labels and use gexp.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 61d959e03f..6e496dbc99 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -995,16 +995,16 @@ with localed.  This package is extracted from the broader systemd package.")
                "1dr1laic65ld95abp2yxbwvijnngh0dwyb1x49x4wjm5rhq43dl8"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f
-       #:make-flags (list (string-append "BASH_COMPLETIONS_DIR="
-                                         %output "/etc/bash_completion.d"))
-       #:configure-flags
-       '("--disable-systemd")))
+     (list #:tests? #f
+           #:make-flags
+           #~(list (string-append "BASH_COMPLETIONS_DIR="
+                                  #$output "/etc/bash_completion.d"))
+           #:configure-flags #~'("--disable-systemd")))
     (native-inputs
-     `(("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)
-       ("glib:bin" ,glib "bin")))
+     (list intltool
+           pkg-config
+           python-wrapper
+           `(,glib "bin")))
     (inputs
      (list glib bash-completion polkit))
     (propagated-inputs