summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-25 02:15:49 -0400
committerMark H Weaver <mhw@netris.org>2018-03-28 00:04:35 -0400
commitd4040f6e23f1777fdf5e402622edea94fa98d2be (patch)
tree26afa1a16e53096ab56eb7ba0610b724792fb892 /gnu/packages/freedesktop.scm
parent78666a68a53750192a714e267f7608094920da49 (diff)
downloadguix-d4040f6e23f1777fdf5e402622edea94fa98d2be.tar.gz
gnu: elogind: Fix build with glibc-2.27.
* gnu/packages/patches/elogind-glibc-2.27.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/freedesktop.scm (elogind)[source]: Add patch.
[arguments]: Replace the bootstrap phase with what was previously the
autogen phase.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c981271e84..a0134c37fe 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -7,7 +7,7 @@
 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
@@ -38,6 +38,7 @@
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (gnu packages)
   #:use-module (gnu packages acl)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages autotools)
@@ -236,6 +237,7 @@ the freedesktop.org XDG Base Directory specification.")
               (sha256
                (base32
                 "1qcxian48z2dj5gfmp7brrngdydqf2jm00f4rjr5sy1myh8fy931"))
+              (patches (search-patches "elogind-glibc-2.27.patch"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -277,7 +279,7 @@ the freedesktop.org XDG Base Directory specification.")
              (substitute* "src/basic/parse-util.c"
                (("xlocale\\.h") "locale.h"))
              #t))
-         (add-before 'configure 'autogen
+         (replace 'bootstrap
            (lambda _
              (invoke "intltoolize" "--force" "--automake")
              (invoke "autoreconf" "-vif")))