summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-24 13:44:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-26 20:13:10 +0100
commit57e7d7486ba17d7b5407ebc429ce8553460371ea (patch)
treebb9514ea3ccdb8063a4e3396b7c0e4d2e638be12 /gnu/packages/freedesktop.scm
parent3c4bbb4c52418c8daf8b0e4605e3912685c9f44a (diff)
downloadguix-57e7d7486ba17d7b5407ebc429ce8553460371ea.tar.gz
gnu: Use HTTPS for supported freedesktop.org home pages.
* gnu/packages/fontutils.scm (fontconfig)[home-page]: Use HTTPS.
* gnu/packages/freedesktop.scm (python-pyxdg, accountsservice)
(modem-manager, telepathy-mission-control, telepathy-mission-control)
(colord-gtk, desktop-file-utils)[home-page]: Likewise.
* gnu/packages/ghostscript.scm (libspectre)[home-page]: Likewise.
* gnu/packages/glib.scm (dbus, dbus-glib, telepathy-glib)[home-page]:
Likewise.
* gnu/packages/gnome.scm (shared-mime-info, hicolor-icon-theme)
(libxklavier, colord, upower)[home-page]: Likewise.
* gnu/packages/gstreamer.scm (orc, python-gst)[home-page]: Likewise.
* gnu/packages/libcanberra.scm (sound-theme-freedesktop)[home-page]:
Likewise.
* gnu/packages/libreoffice.scm (libexttextcat)[home-page]: Likewise.
* gnu/packages/polkit.scm (polkit-gnome, polkit-gnome)[home-page]:
Likewise.
* gnu/packages/pulseaudio.scm (pavucontrol)[home-page]: Likewise.
* gnu/packages/python.scm (python-dbus)[home-page]: Likewise.
* gnu/packages/xdisorg.scm (startup-notification)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 63adb4d076..3c83e668b0 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -409,7 +409,7 @@ manager for the current system.")
      `(("shared-mime-info" ,shared-mime-info) ;for tests
        ("hicolor-icon-theme" ,hicolor-icon-theme) ;for tests
        ("python-nose" ,python-nose)))
-    (home-page "http://freedesktop.org/wiki/Software/pyxdg")
+    (home-page "https://www.freedesktop.org/wiki/Software/pyxdg")
     (synopsis "Implementations of freedesktop.org standards in Python")
     (description
      "PyXDG is a collection of implementations of freedesktop.org standards in
@@ -740,7 +740,7 @@ message bus.")
     (inputs
      `(("shadow" ,shadow)
        ("polkit" ,polkit)))
-    (home-page "http://www.freedesktop.org/wiki/Software/AccountsService/")
+    (home-page "https://www.freedesktop.org/wiki/Software/AccountsService/")
     (synopsis "D-Bus interface for user account query and manipulation")
     (description
      "The AccountService project provides a set of D-Bus interfaces for querying
@@ -840,7 +840,7 @@ which speak the Qualcomm MSM Interface (QMI) protocol.")
        ("libqmi" ,libqmi)
        ("polkit" ,polkit)))
     (synopsis "Mobile broadband modems manager")
-    (home-page "http://www.freedesktop.org/wiki/Software/ModemManager/")
+    (home-page "https://www.freedesktop.org/wiki/Software/ModemManager/")
     (description
      "ModemManager is a DBus-activated daemon which controls mobile
 broadband (2G/3G/4G) devices and connections.  Whether built-in devices, USB
@@ -882,7 +882,7 @@ modems and setup connections with them.")
        ("sqlite" ,sqlite)
        ("telepathy-glib" ,telepathy-glib)))
     (synopsis "Telepathy logger library")
-    (home-page "http://telepathy.freedesktop.org/")
+    (home-page "https://telepathy.freedesktop.org/")
     (description
      "Telepathy logger is a headless observer client that logs information
 received by the Telepathy framework.  It features pluggable backends to log
@@ -909,7 +909,7 @@ different sorts of messages in different formats.")
        ("python-dbus" ,python2-dbus)))
     (propagated-inputs
      `(("telepathy-glib" ,telepathy-glib)))
-    (home-page "http://telepathy.freedesktop.org/")
+    (home-page "https://telepathy.freedesktop.org/")
     (synopsis "Telepathy IRC connection manager")
     (description
      "Idle is an IRC connection manager for the Telepathy framework.  This
@@ -971,7 +971,7 @@ share connections to real-time communication services without conflicting.")
      `(("colord" ,colord)
        ("gtk+" ,gtk+)))
     (synopsis "GTK integration for libcolord")
-    (home-page "http://www.freedesktop.org/software/colord/")
+    (home-page "https://www.freedesktop.org/software/colord/")
     (description
      "This is a GTK+ convenience library for interacting with colord.  It is
 useful for both applications which need colour management and applications that
@@ -1068,7 +1068,7 @@ to applications simultaneously competing for fingerprint readers.")
      `(("pkg-config" ,pkg-config)))
     (inputs
      `(("glib" ,glib)))
-    (home-page "http://www.freedesktop.org/wiki/Software/desktop-file-utils/")
+    (home-page "https://www.freedesktop.org/wiki/Software/desktop-file-utils/")
     (synopsis "Utilities for working with desktop entries")
     (description
      "This package contains a few command line utilities for working with