summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 15:00:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:02 -0400
commit6e64fde873d4d926b75a0e40a9406b9bf2920592 (patch)
treea09d52f76ba5adb4acb3efc66c29b365db9169f2 /gnu/packages/freedesktop.scm
parenta39bc5d1e4d2f69c6e1bd57eef075e5f1798e561 (diff)
downloadguix-6e64fde873d4d926b75a0e40a9406b9bf2920592.tar.gz
gnu: farstream: Remove patch-docbook-xml phase.
* gnu/packages/freedesktop.scm (farstream) [arguments]: Remove
patch-docbook-xml phase.
[native-inputs]: Add libxml2.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 29121ca711..54f7732151 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -263,15 +263,7 @@ application-centers for distributions.")
                 ;; This test timeouts despite changing the value of
                 ;; 'CK_DEFAULT_TIMEOUT' to 600 (see:
                 ;; https://gitlab.freedesktop.org/farstream/farstream/-/issues/20).
-                (("^\ttransmitter/nice.*") ""))))
-          (add-after 'unpack 'patch-docbook-xml
-            (lambda* (#:key native-inputs inputs #:allow-other-keys)
-              (with-directory-excursion "docs"
-                (substitute* '("libs/farstream-libs-docs.sgml"
-                               "plugins/farstream-plugins-docs.sgml")
-                  (("http://www.oasis-open.org/docbook/xml/4.1.2/")
-                   (search-input-directory (or native-inputs inputs)
-                                           "xml/dtd/docbook/")))))))))
+                (("^\ttransmitter/nice.*") "")))))))
     (native-inputs
      (list autoconf
            automake
@@ -280,6 +272,7 @@ application-centers for distributions.")
            gobject-introspection
            gtk-doc/stable
            libtool
+           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            perl
            pkg-config