summary refs log tree commit diff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-01 13:14:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-01 13:52:27 +0100
commitd736eec2ad8359882486129a8c20b8f06e71deae (patch)
treeeaa9bc8656b198caa7184fe18d37e46d5ec38a8a /gnu/packages/ftp.scm
parent69ec039105fda7f523b2c5dbb61b55c156b9fe3d (diff)
downloadguix-d736eec2ad8359882486129a8c20b8f06e71deae.tar.gz
gnu: lftp: Update to 4.7.5.
* gnu/packages/ftp.scm (lftp): Update to 4.7.5.
[source]: Rearrange mirrors.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 5ff56d7eae..7380fcfc3b 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -36,23 +36,19 @@
 (define-public lftp
   (package
     (name "lftp")
-    (version "4.7.4")
+    (version "4.7.5")
     (source (origin
               (method url-fetch)
-              ;; XXX: Downloads from main site redirects to 'get.html' and
-              ;; returns HTTP 200, leading Guix to download that instead.
-              ;; Try official mirror first. See:
-              ;; https://github.com/lavv17/lftp/issues/299 and
-              ;; https://lftp.tech/get.html (mirror list)
-              (uri (list (string-append "ftp://ftp.st.ryukoku.ac.jp/pub/network/"
-                                        "ftp/lftp/lftp-" version ".tar.xz")
-                         (string-append "https://lftp.tech/ftp/lftp-"
+              ;; See https://lftp.tech/get.html for mirrors.
+              (uri (list (string-append "https://lftp.tech/ftp/lftp-"
                                         version ".tar.xz")
                          (string-append "https://lftp.tech/ftp/old/lftp-"
-                                        version ".tar.xz")))
+                                        version ".tar.xz")
+                         (string-append "ftp://ftp.st.ryukoku.ac.jp/pub/network/"
+                                        "ftp/lftp/lftp-" version ".tar.xz")))
               (sha256
                (base32
-                "0b6r1gbpazvml1hvfjm2ccsfxibrjrm3fir912j6kxxn538w8rxz"))))
+                "1n6h3y5jz1rxlx7ap46vykgm0q2rvzr7c5s5ry5l32z3lbmwbdak"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))