summary refs log tree commit diff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 04:42:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 07:14:10 +0200
commita6e8a9c3340e8f6dcee92dcc3f17d8449d282982 (patch)
tree3506106258a21af463e4240cfd4713554edd67a9 /gnu/packages/ftp.scm
parent4049fa8e52ced1fab2d6d013ffa45e819e3c8676 (diff)
downloadguix-a6e8a9c3340e8f6dcee92dcc3f17d8449d282982.tar.gz
gnu: vsftpd: Let the build system create directories.
* gnu/packages/ftp.scm (vsftpd)[arguments]: Pass the "-D" flag to
‘install’.  Remove the now redundant 'mkdir phase.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index c79991e3af..5d07052b39 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -270,7 +270,8 @@ directory comparison and more.")
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
-       (list "LDFLAGS=-lcap -lcrypt -lpam")
+       (list "LDFLAGS=-lcap -lcrypt -lpam"
+             "INSTALL=install -D")
        #:tests? #f                      ; no test suite
        #:phases
        (modify-phases %standard-phases
@@ -284,17 +285,7 @@ directory comparison and more.")
          (add-after 'unpack 'patch-installation-directory
            (lambda* (#:key outputs #:allow-other-keys)
              (substitute* "Makefile"
-               (("/usr") (assoc-ref outputs "out")))
-             #t))
-         (add-before 'install 'mkdir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (mkdir-p out)
-               (mkdir (string-append out "/sbin"))
-               (mkdir (string-append out "/man"))
-               (mkdir (string-append out "/man/man5"))
-               (mkdir (string-append out "/man/man8"))
-               #t)))
+               (("/usr") (assoc-ref outputs "out")))))
          (delete 'configure))))         ; no configure script
     (inputs
      `(("libcap" ,libcap)