summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-17 17:13:03 +0100
committerMarius Bakke <marius@gnu.org>2021-12-17 19:07:17 +0100
commite0559c531425da5a689d14553af7873528b49d09 (patch)
treea26e6cb317d55dc4fb3292d2e42d97ea76b2b8da /gnu/packages/game-development.scm
parentd080368cb5159613a1ff6611e55e09b62977383e (diff)
downloadguix-e0559c531425da5a689d14553af7873528b49d09.tar.gz
gnu: grfcodec: Fix build with GCC 10.
* gnu/packages/patches/grfcodec-gcc-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/game-development.scm (grfcodec)[source](patches): New field.
[arguments]: Remove trailing #t.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 19d5e71506..d7502dbc29 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -213,6 +213,7 @@ DeuTex has functions such as merging wads, etc.")
        (uri (string-append "https://binaries.openttd.org/extra/"
                            name "/" version "/" name "-" version
                            "-source.tar.xz"))
+       (patches (search-patches "grfcodec-gcc-compat.patch"))
        (sha256
         (base32 "08admgnpqcsifpicbm56apgv360fxapqpbbsp10qyk8i22w1ivsk"))))
     (build-system gnu-build-system)
@@ -238,8 +239,7 @@ DeuTex has functions such as merging wads, etc.")
                              "readme" "readme.rpn"))
                  (for-each (lambda (file)
                              (install-file file man))
-                           (find-files "." "\\.1"))))
-             #t)))))
+                           (find-files "." "\\.1")))))))))
     (inputs
      (list boost libpng zlib))
     (synopsis "GRF development tools")