summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-06 17:22:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-06 18:44:19 +0100
commit497a4646b37843187851787e34cc99683799f345 (patch)
tree232a201f959afee0d866248fbf6fed07f57c6b20 /gnu/packages/game-development.scm
parent94466f9594789f5320a79fa5555254e0b4a90f5b (diff)
downloadguix-497a4646b37843187851787e34cc99683799f345.tar.gz
gnu: surgescript: Do not want static libraries.
* gnu/packages/game-development.scm (surgescript)[arguments]:
Add "-DWANT_STATIC=NO" to #:configure-flags.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 55a7d71c17..7e17142b9e 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -652,7 +652,8 @@ sounds from presets such as \"explosion\" or \"powerup\".")
      (arguments
       '(#:configure-flags
         (let ((share (string-append (assoc-ref %outputs "out") "/share")))
-          (list (string-append "-DICON_PATH=" share "/pixmaps")
+          (list "-DWANT_STATIC=NO"
+                (string-append "-DICON_PATH=" share "/pixmaps")
                 (string-append "-DMETAINFO_PATH=" share "/metainfo")))
         #:tests? #f))
      (home-page "https://docs.opensurge2d.org")