summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorAndrew Whatson <whatson@gmail.com>2022-10-21 22:22:53 +1000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-22 13:50:49 +0200
commitd49d21654a05316670d46d7586caa6c1565019ee (patch)
tree6f43aa65b852e213f688a9abd0d3623abc6b02bd /gnu/packages/game-development.scm
parentefaefc1deb43b36cc4c0303f54eb6b3961f1236c (diff)
downloadguix-d49d21654a05316670d46d7586caa6c1565019ee.tar.gz
gnu: libresprite: Install a desktop icon.
* gnu/packages/game-development.scm (libresprite)[arguments]
<#:configure-flags>: Add “-DWITH_DESKTOP_INTEGRATION=1”.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index d40a97eef2..4afb7f8437 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1088,7 +1088,8 @@ the creation of animations, tiled graphics, texture atlases, and more.")
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags
-       (list "-DWITH_WEBP_SUPPORT=1")
+       (list "-DWITH_WEBP_SUPPORT=1"
+             "-DWITH_DESKTOP_INTEGRATION=1")
        ;; Tests are unmaintained
        #:tests? #f))
     (native-inputs