summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-10 13:18:11 -0400
committerKei Kebreau <kei@openmailbox.org>2017-05-10 20:00:50 -0400
commit1b775fd1df9e4c4f96e9acdf5485d04a74730153 (patch)
tree40ea0fd1bbfdb3a6c6f493c70d5a6fa4faf6e5c1 /gnu/packages/game-development.scm
parent45f8e7f75e5401eb05bf98383ee169f6b7f06851 (diff)
downloadguix-1b775fd1df9e4c4f96e9acdf5485d04a74730153.tar.gz
gnu: Add python-tmx.
* gnu/packages/game-development.scm (python-tmx, python2-tmx): New
variables.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 75ab59b1b3..da3a850fed 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -214,6 +214,41 @@ possible, and it also makes the SGE easy to learn.")
 (define-public python2-sge-pygame
   (package-with-python2 python-sge-pygame))
 
+(define-public python-tmx
+  (package
+    (name "python-tmx")
+    (version "1.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://savannah/python-tmx/tmx-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1is107sx3lr09dqjiyn10xqhyv5x54c2ryhys9mb9j3mxjbm227l"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (home-page "http://python-tmx.nongnu.org")
+    (synopsis "Python library for the @code{Tiled} TMX format")
+    (description
+     "Python TMX reads and writes the @code{Tiled} TMX format in a simple way.
+This is useful for map editors or generic level editors, and it's also useful
+for using a map editor or generic level editor like Tiled to edit your game's
+levels.")
+    (license (list license:asl2.0
+                   ;; Documentation (only available in the source tarball) is
+                   ;; under the CC0 license.
+                   license:cc0))))
+
+(define-public python2-tmx
+  (let ((python2-tmx (package-with-python2 python-tmx)))
+    (package
+      (inherit python2-tmx)
+      (propagated-inputs
+       `(("python2-pathlib" ,python2-pathlib)
+         ,@(package-propagated-inputs python2-tmx))))))
+
 (define-public tiled
   (package
     (name "tiled")